Contents for Object Packager Help

Object Packager is a tool you can use to create an icon that represents an embedded or
linked object and then insert the icon into a document.

To learn how to use Help, press F1.
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What Is Object Packager?

Object Packager is a tool you can use to create a package and then insert it into a
document. A package is an icon that represents an embedded or linked object. An object
may be a complete document or part of one. For example, both a spreadsheet cell and an
entire drawing are objects.

The Object Packager application window is split into two smaller windows. The window on
the left, the Appearance window, displays the icon that represents the embedded or
linked object in the destination document. The window on the right, the Content window,
displays the name of the document that contains the object or a presentation of the
object.

To create a packaged object, you copy the contents of the Appearance and Content
windows onto the Clipboard. The contents of the Clipboard becomes the package when it
is inserted into a document. You can only insert a package into Windows applications that
accept linked or embedded objects. These are called client applications.

You can activate or edit a package. Depending on the contents of the package, one of two
things happens when you activate a package. If the package contains a sound or
animation file, activating the package plays the sound or animation. If the package
contains a picture, text, or spreadsheet, the application that was used to create the
contents of the package opens, with the package contents (the linked or embedded
object) displayed. For example, if the package contains a Paintbrush drawing, Paintbrush
opens, displaying the drawing.

When you edit a package, Object Packager opens and you can change the contents of the
package or the package label.

To return to Contents for Object Packager Help, choose the Contents button.




Rules for Creating a Package

There are two ways to create a package. The methods available depend on the
application you are using, where you are starting your task from, and whether you are
embedding or linking an entire document or part of one.

Applications that support object linking and embedding fall into two categories.
Applications whose objects can be embedded or linked into other documents are called
servers. Applications that can accept embedded or linked objects are called clients. Some
applications may be both a server and a client. Others are only one or the other.

If you want to package only a part of a document, you must use Object Packager to
create the package, and the document must have been created using a server
application.

If you want to package a complete document, you can use either Object Packager or File
Manager. The contents of the package can be created using any application, not only one
that supports object linking and embedding.

Regardless of the package contents, a package can only be inserted into a document that
has been created by using a client application.

To return to Contents for Object Packager Help, choose the Contents button.



Editing a Package

When you edit a package, Object Packager opens and you can change the label, icon, or
contents of the package.

To edit a package
1 Open the document that contains the package, and then select the package.
2 From the Edit menu, choose Package Object.
3 From the Package Object cascading menu, choose Edit Package.
Object Packager opens, and you can make your changes.
4 From the File menu in Object Packager, choose Update.
5 Quit Object Packager.

See Also
Changing an Icon
Changing a Label




Creating a Package that Contains a Complete Document

When you create a package, you embed or link an object into Object Packager. The
embedded or linked object can be either a complete document or part of one.

To create a package that contains a complete document
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From the File menu in Object Packager, choose Import.

In the Import dialog box, select the document you want to package, and then choose
the OK button. You can import any document into Object Packager regardless of
whether the application used to create it supports object linking and embedding.

The icon of the application used to create the file appears in the Appearance window,
and the name of the file appears in the Content window.

From the Edit menu, choose Copy Package.
The contents of the two windows are placed onto the Clipboard.

Open the document into which you want to place the package. This document must
have been created by using a client application.

If applicable, move the cursor to the place you want the package to appear.

In some applications, the package is automatically placed in the upper-left corner of
the window.

From the application's Edit menu, choose Paste.

The package appears as an icon in the document.

See Also
Changing an Icon
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Creating a Package that Contains Part of a Document

When you create a package, you embed or link an object into Object Packager. The
embedded or linked object can be either a complete document or part of one.

To create a package that contains part of a document
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Open the document that contains the information you want to package. The
document must have been created by using a server application.

Select the information you want to package.
From the application's Edit menu, choose Copy.
Open Object Packager.

Select the Content window.

From the Edit menu in Object Packager, choose Paste to embed the information into
Object Packager, or Paste Link to link it.

From the Edit menu in Object Packager, choose Copy Package.

Open the document into which you want to insert the package. This document must
have been created by using a client application.

If applicable, move the cursor to the place you want the package to appear.

In some applications, the package is automatically placed in the upper-left corner of
the window.

From the application's Edit menu, choose Paste.
The package appears as an icon in the document.

If you are working with applications that support object linking and embedding and you
have a mouse, you can embed or link documents by dragging their icons from File
Manager into the client application window.

See Also
Changing an Icon
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Changing an Icon

When you embed or link an object into Object Packager, the Appearance window shows
the icon that will appear in the destination document. By default, this is the icon for the
application used to create the object.

You can change this icon to another application's icon or to a picture you create. You can
change the icon before or after the object has been embedded or linked into Object
Packager.

To change an icon
1 In the Appearance window, choose the Insert Icon button.
The Insert Icon dialog box appears.

2 In the File Name box, type the name of the program file for the application whose icon
you want to use; for example, PBRUSH.EXE.

Or choose the Browse button. In the Browse dialog box, select a program file, and then
choose the OK button. Then select an icon, if more than one is available.

3 Choose the OK button.
The icon you selected is displayed in the Appearance window.

See Also
Creating a Package that Contains a Complete Document
Creating a Package that Contains Part of a Document

Creating a Custom Icon




Creating a Custom Icon

You can use a graphics application to create a custom icon for the package.

To create your own icon
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Open Paintbrush or another drawing application.

Create a drawing, or open the file that contains the drawing you want to use for the
icon.

Copy the drawing onto the Clipboard.

Open Object Packager.

Select the Appearance window by clicking the window or pressing TAB.
From the Edit menu, choose Paste.

Your drawing appears in the Appearance window. When you create your own icon, the
package does not have a label.

See Also
Creating a Package that Contains a Complete Document

Creating a Package that Contains Part of a Document
Changing an Icon



Changing a Label

Each package has a label that describes what it contains.

You can edit this label except under certain circumstances, such as when you are using a
custom image you created.

To change a label
1 From the Edit menu in Object Packager, choose Label.

The Label command is only available when the icon for the package is in the
Appearance window.

2 Type the text for the new label.
3 Choose the OK button.

See Also

Creating a Package that Contains a Complete Document
Creating a Package that Contains Part of a Document
Editing a Package




Inserting an MS-DOS Command into a Document

You can package an MS-DOS command and then embed this package into a document.
Activating the package carries out the command. For example, you could run a batch
program or start another application.

To insert an MS-DOS command as a package
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From the Edit menu in Object Packager, choose Command Line.

In the Command box, type a command (including any options or parameters). If you
are typing the name of a program file, include the full path and filename extension.

Choose the OK button.

The command appears in the Content window.

Choose the Insert Icon button.

In the Current Icon area of the Insert Icon dialog box, select an icon.

Or choose the Browse button. In the Browse dialog box, select a program file, and
choose the OK button. Then choose an icon.

Choose the OK button.
The icon appears in the Appearance window.
From the Edit menu, choose Copy Package.

Open the document you want to place the package into, and, if applicable, move the
cursor to the place you want the package to appear.

In some applications, the package is automatically placed in the upper-left corner of
the window.

From the application's Edit menu, choose Paste.
The command appears as a package in the document.

To run the program or carry out the command, activate the package.



Using the Mouse to Insert a Package

You can use File Manager to quickly insert a package into a document. When you use this
method, the package can only contain a complete document.
Note: You can only insert a package into a document that was created by using a client

To use a mouse to insert a package

1 Open the destination document.

2 Open File Manager.

3 In File Manager, select the directory that contains the source document. Make sure that
both the File Manager window that contains the source document and the window that
contains the destination document are visible.

4 To insert a package that contains an embedded document, drag the icon of the source
document into the window containing the destination document.

To insert a package that contains a linked document, press SHIFT+CTRL while you drag
the icon.
The package appears in the destination document.

See Also

Creating a Package that Contains a Complete Document
Creating a Package that Contains Part of a Document




Updating a Linked Object

When creating a package that contains a linked object, you need to choose how the
presentation of the linked object will be updated in the destination document when the
source document it is linked to changes.

The presentation of the linked object can be updated either automatically or manually. By
default, it is updated automatically. If you select the Manual update option, the
presentation of the linked object is updated only when you choose to update it.

A package that contains linked objects can be updated in Object Packager or in the
destination document. Either way, you do not see the updated information until you
display the contents of the package.

To change the way a linked object is updated
1 From the Edit menu, choose Links.

The Links command is only available when there is a linked object in the Content
window.

2 In the Links dialog box, select the Automatic or Manual option.
3 Choose the OK button.

To manually update a linked object
1 From the Edit menu, choose Links.

The Links command is only available when there is a linked object in the Content
window.

2 In the Links dialog box, choose the Update Now button.
3 Choose the OK button.

See Also

Creating a Package that Contains a Complete Document
Creating a Package that Contains Part of a Document




Editing an Embedded Object

You can edit an embedded object from Object Packager.

To edit an embedded object
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In the destination document, select the package that contains the embedded object
you want to edit.

From the application's Edit menu, choose Package Object.

From the Package Object cascading menu, choose Edit.

Object Packager opens.

Double-click the text or picture displayed in the Content window.

Or select the Content window, and then choose the name of the object from the Edit
menu (for example, Paintbrush Picture Object).

The application opens with the object displayed.
Edit the object.
From the application's File menu, choose Update.

The embedded object is updated in Object Packager. If you have Picture selected in the
Content window, you will see the changes.

From the application's File menu, choose Exit & Return To (name of document).

The application closes, and you can continue working in Object Packager.

See Also

Creating a Package that Contains a Complete Document
Creating a Package that Contains Part of a Document

Switching Between Description and Picture View




Editing a Linked Object

You can edit a linked object from Object Packager. Any changes you make to a linked
object appear in all the documents containing links to it.

To edit a linked object
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In the destination document, select the package that contains the linked object you
want to edit.

From the Edit menu, choose Package Object.

From the Package Object cascading menu, choose Edit.

Object Packager opens.

Double-click the text or picture displayed in the Content window.

Or select the Content window, and then choose Links from the Edit menu. Then in the
Links dialog box, choose the Edit button.

The application opens with the object displayed.

Edit the object.

From the application's File menu, choose Save.

From the application's File menu, choose Exit.

The application closes, and you can continue working in Object Packager.

If you have Picture selected in the Content window, you will see the changes.

If the linked object is set to update manually, you must update the link using the Links
dialog box to see your changes.

See Also
Creating a Package that Contains a Complete Document

Creating a Package that Contains Part of a Document

Updating a Linked Object



Switching Between Description and Picture View

There are two ways you can view what is displayed in the Content window. Description
View displays a textual description of the object. For linked objects, it is the name of the
file that contains the linked object. For embedded objects, it is a description of the type of
object.

Picture View displays a snapshot view of the object. Picture View is only available when

the object was created by using a server application and when the Clipboard was used to
transfer the object into Object Packager. Description view is the default view.

To switch between Description and Picture views
1 Select the Content window by either clicking the window or pressing TAB.

2 Select the Description or Picture option by either clicking the button or pressing ALT+D
for Description or ALT+P for Picture.



Edit Menu Commands

Use the scroll bar to see more commands.

Undo

Undoes the last change made in the selected window. For example, if the Appearance
window is selected and you choose this command, only the most recent change made in
the Appearance Window is undone.

Cut

Deletes the contents of the selected window, not the complete package, and places it
onto the Clipboard. This command is available only if there is an icon in the Appearance
window.

Copy

Copies the contents of the selected window, not the complete package, and places it onto
the Clipboard. This command is available only if there is an icon in the Appearance
window.

Delete
Deletes the contents of the selected window (not the complete package).

Paste
Embeds an object from the Clipboard into Object Packager.

Paste Link
Links an object from the Clipboard into Object Packager.

Copy Package
Copies the contents of the Appearance and Content windows onto the Clipboard, thus
creating a packaged object. You can then place the package into a destination document.

Links

Changes the behavior and appearance of a linked object. You can use this command to
change the way a linked object is updated, manually update the linked object, change the
source document of the linked object, or activate, edit, or cancel links.

Label
Changes the label of the icon that is displayed in the Appearance window.

Command Line

Creates a package that contains an MS-DOS command so that you can run a batch
program or start an application from another application.

Object
Displays the object in its application window.

This command changes to reflect the contents of Object Packager; for example,
Paintbrush Picture Object.



File Menu Commands

Use the scroll bar to see more commands.

New
Clears the contents of the Appearance and Content windows.

When you choose New, you can save changes to the current package before creating a
new package.

Update
Updates the package in the document from which Object Packager was opened.

This command is available only when Object Packager is opened from another
application.

Import

Places a file in Object Packager.

When you import a file to Object Packager, the icon of the application used to create the
file appears in the Appearance window, and the name of the file appears in the Content
window.

Save Contents

Saves the displayed object to a new file. You can use this command to save the object to
a file with a new name only if it was previously saved (brought into Object Packager by
using the Import command or File Manager).

Exit
Quits Object Packager.
You can save the contents of Object Packager before quitting.






